Before We Begin

1. Go to wp.me/a5G4dR-1dw, and click the

Crash-Course-Unity-2018-Assets link to download the
ZIP file, “Crash-Course-Unity-2018-Assets.zip”.



https://wp.me/a5G4dR-1dw
https://techvalleygamespace.com/wp-content/uploads/2018/09/Crash-Course-Unity-2018-Assets.zip
https://techvalleygamespace.com/wp-content/uploads/2018/09/Crash-Course-Unity-2018-Assets.zip

Crash Course Unity 3D

Introduction to how to use Unity




Get comfortable with Unity game editor
Create an interactive 3D environment
Learn lots of 3D development terms

A brief start in C# programming



Supplementary materials

e http://unity3d.com/learn/tutorials
a. Official site full of tutorials on individual
Unity feature
b. Includes in-depth C# programming
tutorials!



http://unity3d.com/learn/tutorials

Starting a new project

Step 1: Click "New”

« Open |@} My Account



Starting a new project

Step 2: Type in a project name and the folder it'll be

created in.
Note: Unity will create a new folder with the project’s name

New Unity Project 3D

/Users/Documents Add Asset Package




Starting a new project

Step 4: Click "Add Asset SEEhEe e

e

Package”, and check “Standard ] shader Forge

Assets.” Lastly, click "Done.” -
B’St@ﬁiard Assets

[ ] Unity Anima2D
(] Unity IAP
(] Unity Particle Pack

(] Unity Particle Pack

e m



Starting a new project

Step 5: Finally, click “Create project”

New Unity Project 3D v

/Users/Documents [ Add Asset Package ]

w ON {fj@\' Enable Unity Analytics (?)




Importing stuff

1. Copy all the files in
Crash-Course-Unity-2018-Assets.zip into the
project’s Assets folder using your favorite file browser.

The files include:
a. Level.fbx

b. Grass.png

c. Rock.jpg

d. Hit.wav

e. DragRigidbody.cs
S

2. Switch to Unity.



Asset License

Original files obtained from:

http://opengameart.org/content/machu-picchu

o level.fbx is a modified version of MPFull.blend from
ctdabomb, released under CC-by-sa 3.0

e grass.png is from samuncle, released under CC-by-sa
3.0

e rock.jpg is from Marianne Gagnon , release under
CC-by-sa 3.0

Link to CC-by-sa 3.0 license:

https://creativecommons.org/licenses/by-sa/3.0/legalcode



http://opengameart.org/content/machu-picchu
https://creativecommons.org/licenses/by-sa/3.0/legalcode

About Unity
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What is Unity?

e A What-You-See-Is-What-You-Get (WYSIWYG) 3D & 2D
Game Engine

e Many built-in features
o Physics, Sound, Scripting, Gamepad support, Plugins, and
more!
e Builds to many platforms
o PC, Mac, Linux, HTML5 + WebGL, iOS (iPhone + iPad),

Android, Facebook Gameroom, Windows 10, PS4, Xbox
One, Switch, etc.



Licenses and Fees

e Free license (what we're using now!)

©)

Build to Windows, Mac, Linux, Facebook Gameroom, HTML5 +
WebGL, iOS, Android, and Windows 10

C# scripting support
Totally OK to sell your game! There’s no royalty fees.
m Exception: if your company’s gross revenue/budget exceeds

$100,000, you need to purchase...

e If company gross revenue/budget exceeds $100,000...

O
O
O

Check out the paid license in the URL below:

store.unity.com
Plus ($35/month) and Pro ($125/month) license provides cool

web-related services, e.g. servers for multiplayer.



https://store.unity.com/

Making a game
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Project Pane

e Displays the contents of the Assets folder.
o Automatically syncs with the folder if there’s any changes

e Has a search bar to make it easier to find assets

1 Project | Bconsole | @@9' « Fossil » SiggraphIntroToUnity »
Create * == — = —_— —
¥ /Favorites Assets » Share with v Burn New folder
©LAll Materials
S8 Modeln ¢ Favorites Fossil library B = o
(LAl Prefabs <ohlntroTol ange
"v‘—:”A" Scripts = Desktop SrggraphintroToUnity
: & Downloads
e Standard A..
'%—":"éjt‘::*‘d o e | Recent Places
& Standard As
Dropbox
& Google Drive L PfOJ:;tSSEﬁ' Temp
£ Recycle Bin
|

s Libraries



Add a model to a nhew scene

1. Select level.fbx in the Project |=& ==t
pane. ~

2. Drag-and-drop level.fbx into
the Scene pane.

3. In file menu, select “File ->
Save Scene as...” to save the

Scene! Edit Assets GameObject Compol

New Scene Ctrl+N
Open Scene Ctrl+0
Save Scene Ctrl+S

Save Scene as... Ctrl+Shift+S




Quick lexicon review

e Assets
o Industry-wide term for any files used in the game
o For Unity, that’s anything inside the Assets folder

e Models
o Industry-wide term for 3D sculpture files.
o Can contain animations.
o Usually made in a specialized program, e.g. Maya, Blender, etc.



Scene Pane

e A 3D view of a scene where objects can be positioned,
rotated, and scaled.

| Shaded vll20]| % || @] - - | Gizmos »| Al




Importing 3D models

Unity can natively import:

FBX (*.fbx)

COLLADA (*.dae)

3D Studio (*.3ds)

Wavefront (*.0bj)

Draw Interchange Files (*.dxf)



Importing 3D models

If you have the following software installed on the same
computer Unity is, Unity can also import:

Blender (*.blend)

Maya (*.mb, *.ma)

3D Studio Max (*.max)

Modo (*.Ix0)

Cinema4D

Cheetah 3D (*.jas)

Lightwave



Navigating the scene pane

e 2-button mouse:
o Left-click to select objects
o Hold alt and left mouse button to rotate camera around scene origin
o Hold ctrl, alt, and left mouse button to pan
o Hold ctrl, alt, and right mouse button to zoom

e 3-button mouse:
o Left-click to select objects
o Hold right mouse button to rotate camera around camera position
o Scroll wheel to zoom in and out
o Click and hold on the scroll wheel to pan

e Hold shift to pan/rotate/zoom faster



Navigating the scene pane

e Rotation Lock
o Toggles whether rotation is enabled or not.

e AXis Snap

o Click on any cones to snap the view to that axis.

e Camera Toggle
o Toggles between perspective and orthogonal.
o Orthogonal view creates the isometric view, i.€. =
the lack of a vanishing point.

< Persp



Manipulating game objects

e Object controls, from left to right: [@[#[S=[E
o Pan View (Q)

o Translate (W)

o Rotate (E)

o Scale (R) — =

o 2D Sprlte (T) Translate (W) Rotate (E) Scale (R) Super-Tool (Y)

O SU per'TOOI (Y) | = Center| @ Local |

e C(Controls to toggle object’s reference point:

e Play Game controls, from left to right:
o Play game (or if already playing, stop game)
o Pause game (or if already paused, resume game)
o Move forward one frame



Hierarchy Pane

e Displays the content of a scene in a tree
hierarchy.

e (Objects selected in the Hierarchy-pane
are also selected in the Scene-pane, and
vice versa.

e You can change the order of the objects
by dragging them up and down

e Dragging objects into another turns that
object into a child (I'll go over this later)

“= Hierarchy

ate ~ cwAll

v Q SampleScene*
Main Camera
level
Directional Light

L




Quick lexicon review

e Game Objects
o Unity’s term for any individual object
o Can be active or inactive
o Every entry in the Hierarchy pane is a game object

e Scene
o Unity’s term for files storing a collection of game objects
o Store references to assets in the Assets folder
o Has a *.unity file extension



Creating materials

S

Select Create in the Project pane.

a. Note: right-clicking in the Project pane brings up

the same context menu.
Select Material.
Change the name of the material to

“Grass”.

| Crea

23 Project

t >
Ij&lorites

| [ Console

. Assets *»

All Materials

Scene
Prefab

Audio Mixer

Material
Lens Flare
Render Text
Lightmap Pa
Custom Ren

Grass|




Adding Texture to Material

1. In the Inspector pane,
drag-and-drop texture grass.png ﬂ
into material Grass’ Albedo field. g™ .

2. Reduce the Metallic and o
Smoothness field to 0.

3. Feel free to adjust the color field
next to the Albedo field to one’s
favorite color!




Applying Material to Model

1. From the Project pane,
drag-and-drop the Grass material
to the level model in the Scene
pane.

2. Create a new material, Rock, and

repeat the process with texture
rock.jpg.




Quick lexicon review

e Material

o Industry-wide term for what material the surface of a model is
supposed to look like (e.g. metal, plastic, non-shiny stuff)
o In Unity, materials are files (*.mat) shared between game objects
m Changing a material’s properties will update all game objects with

the same material

o Models retain information on how materials are mapped to its surface

o Normally, you have to create materials
by hand
m Unity conveniently made 2 for us!
o The Renderer component holds materials

@ Project | [ console

Create ~ - :
i":f"-'A" Models 4| Assets » Materials
‘LAl Prefabs T

‘O All Scripts P
vii Assets St
b Ga Editor

grass_dark  HortonRoc..

| w& standard Ass



Inspector Pane

° Displays the pI’OpertieS and OAInSQL;elc::; - l:]Static;:!%l

-l

details on a selected object/file, || o et ;133;;““"'tw=u

both in Project pane and Scene  [F&, e @

Position
Rotation X -90 YO 20

pa ne- Scale X 40 Y 40 Z 40
e One can edit the properties of an [|7 ., teve! Cesh Filten) Q=
object here. e —

Receive Shadows [

b Materials
Use Light Probes M
Reflection Probes | Blend Probes s

Anchor Override None (Transform) N




Importing Images

Unity can natively import:

Photoshop (*.psd)

PNGs (*.png)

JPEGs (*.jpg, *.jpeg)
Un-animated GIFs (*.gif)
Paint (*.bmp)

TGAs (*.tga)

and more!



Quick lexicon review

e T[extures
o Industry-wide term for images that represents how a model is
supposed to be painted
o Models usually contains coordinates (called UV) that indicate how a
texture is supposed to be mapped on the model

e Components

Unity’s term for containers with specialized information

Game objects retain a list of components (such as Transform)
Can be enabled or disabled

Every entry in the Inspector pane is a Component

© O O O



Adding Camera

Let’s add a prefab (short for prefabricated object) with first-person controls

1.

2.

3.

In the Hierarchy pane, select "Main Camera", and remove it by pressing
Delete/Cmd+Backspace. o —

In the Projects pane, search for L o | =
"FPSController" |9
Drag-and-drop "FPSController" 1
into the Scene pane.

Position the FPSController

above the ground

Create - <. FPSController |

All Models

All Prefabs ‘
V l Assets

» @ SampleScen  FPSControl.,  RigidBodyF..



Playing the Game

1. Press the play button. IR
2. Observe your camera...fall through the floor.
3. Press the play button to stop the game.

4. What are we missing?



Adding a Collider

Add Component

The ground needs a collider =
1. In Scene pane, select level. <

~% Rigidbody

2. In the Inspector pane, click "Add 4 hracter Contler

iy Box Collider

Component” @sshere Coler

¥ Capsule Collider

3. Select "Physics -> Mesh Collider" ——-{ I ——

©) Wheel Collider
# Terrain Collider

\» Cloth

“#Hinge Joint
“ Fixed Joint
v ;i M Mesh Collider @ =
Convex ]
Is Trigger

| Material None (Physic Material) ©
ll Mesh U Level [o]




Playing the Game

1. Press the play button. IR

2. Use the mouse to look around, arrow keys (or WASD)
to move, space to jump, and shift to run.

3. Marvel at your own work.



Quick lexicon review

e Prefab

o Unity’s term for prefabricated objects
o Files with *.prefab file extension
o Allows copying a group of game objects from one scene to another

e Colliders
o Industry-wide term for shapes representing the boundaries of an
object
o Used by the physics engine to determine where objects collide



Types of colliders

e Mesh Colliders

o Collider that is the shape of a model’s surface
o Expensive and inefficient
o Best for static, non-interactable levels and objects

e Box Colliders
o Rectangle-shaped colliders

e Sphere Colliders

o Sphere-shaped colliders (no oval support)

e Capsule Colliders
o Capsule-shaped colliders (supports height, no oval support)



Adding interactive stuff

GameObject | Component MobileInput Window Help

1. Select “3D Object -> Cube” =y
2. In the Scene pane, position the @ »o= ok

new cube in front of the camera.
3. While leaving the "Cube" selected,
click "Add Component" under the
Inspector pane.
Select "Physics -> Rigidbody"
Play the game!

el 5=

{ < Physics

£
< Rigidbody =

:-.- Character Controller rl



Using a Script

1.

In the Project pane, select "DragRigidbody.cs"

2. Drag-and-Drop DragRigidbody.cs onto the
"FPSController" under the Hierarchy pane (NOT the
Scene pane!).

Play the game!

Look at the Cube, and click+hold the left mouse button
to pick it up.

W



Making weird shapes

1. Select “"3D Object -> Sphere”

2. In the Scene pane, position the new
sphere on an edge of a cube.

3. In the Hierarchy pane, drag & drop
the Sphere into the Cube.

4. The Sphere should now be a child of
Cube.

5. Play the game, and drag around the
cube+sphere!




Quick lexicon review

e Rigid Body
o Industry-wide term for a moving and/or interactive physics objects
o Contains information such as mass, drag, and center-of-gravity
o Turns a group of colliders (including those in the children) into a
single, interactable shape
e Child
o Industry-wide term for an object whose position, scale, and rotation
follows that of another object: the parent
o In Unity, they appear as nested entries in the Hierarchy tree view
o Trivia: this “following parent” calculation process is known as forward
kinematics, a term in 3D animations



Change some physics

NS

Right-click the Project pane, and
select “Create -> Physics Material”
Name the file, “bouncy”

In the Inspector pane, change the
bounciness to 1 (as in, 100%)

Delete

© Inspector |

© bouncy

Dynamic Friction
Static Friction
Bounciness
Friction Combine

Bounce Combine

m =
@ = =
[ open |
0.6
0.6
i |

[ Average

[ Average




Change some physics

1. In the Hierarchy pane, select Cube

2. Drag & drop “bouncy” from the Project pane to Material
field under the Box Collider component in the Inspector
pane

3. Play the game, and throw the Cube end into the ground

v iy ¥ Box Collider @ %

o Ul] Edit Collider

, Is Trigger L]
,__\;@Material None (Physic Material) (]
enter

X0 Y0 Z0

X1 Yil Z\1




Quick lexicon review

e Physics Material

©)

Industry-wide term for how objects are supposed to interact to a
collider

m Adjusts how slippery and bouncy an object can be
In Unity, materials are files (*.physicMaterial) shared between game
objects
Changing a physics material’s properties will update all game objects
with the same physics material



Adding a Sound

Select the Cube in the Scene pane ‘ il

@Audio Listener

2. In the Inspector pane, click "Add < huio Source

—

Component” . S —
3. Select "Audio -> Audio Source" Vone (hudi Fiver G ©
. arme |- O
4. In the Project pane, oo e e
— . Bypass Rever b Zone[_]
drag-and-drop hit.wav into the Py o
Audio Source component's "Audio o
Clip" property =
5. Play the game! i G




Adding a Script

R Wi

=

Select the Cube in the Scene pane

In the Inspector pane, click "Add Component”

Select "New Script”
Change the script type to CSharp, and the
script name to "PlaySoundOnCollision”
Click “Create and Add”

Double-click "PlaySoundOnCollision" in the
Inspector pane to open Editor

Pla

New Script

aaaaaaaa

y Sound On Collision (Script) [@ %%

L

PlaySoun donCollisior] ©




Copy the Following:

using UnityEngine;
public class PlaySoundOnCollision : MonoBehaviour
AudioSource audio;
vold Start () {
audio = GetComponent<AudioSource> () ;
}
vold OnCollisionEnter (Collision info) {
audio.Stop () ;
audio.Play () ;



Finishing the Sound Effect

1. Save the script (under “File” in the menu bar)

2. Switch to Unity

3. Select the cube in the Scene pane

4. Under the Inspector, uncheck Audio Source's "Play-On

Awake"

5. Play the game! e T Qe
Output None (Audio Mixer GroL @
Mute L]
Bypass Effects ]
Bypass Listener Effe [ ]
Bypass Rever b Zone[ |
Play On Awake ™

Loop ]



Script Summary

AudioSource audio;
void Start () {

=

audio = GetComponent<AudioSource> () ;

The start () function runs when the game starts
GetComponent<AudioSource> () gets the Audio
Source component from the Game Object this script is
attached to

audio = GetComponent<AudioSource> () stores
the Audio Source Component in a variable, audio



Script Summary

volid OnCollisionEnter (Collision info) {
audio.Stop () ;
audio.Play () ;

1. TheonCollisionEnter () function runs when the
Rigidbody collides with a collider

2. audio.Stop () makes the sound effect stop, resetting
it back from the beginning

3. audio.Play () makes the sound effect play again



Importing Sound

Unity can natively import:
e WAV (*.wav)
o Best for short sound effects
e AIFF (*.aif, *.aiff)
o Best for short sound effects
e MP3 (*.mp3)
o Best for music, especially in mobile devices
o Remember, some mobile devices can only play one MP3 file at once

e OGG (*.099)

o Best for music, especially PC and consoles



Duplicating the Cube

1. Drag & Drop the object, "Cube" from the Hierarchy
pane to the Project pane. This creates a new

Prefab.
2. Drag & Drop the Cube prefab from the Project pane

to the Scene pane as many times as you like. This
will create many copies of Cube e

C Sphere
@ Project | [ conso le
Create ~
v Favorites

Il dI

biS




Importing Normal Maps

1. In the Project pane, select grass.png,
and press Ctrl+D/Cmd+D to duplicate it.

grass (DTN

2. Click on grass 1.png. T

3. In the Inspector, change the Texture S
Type to “Normal map”. e e

4. Check “Create from Grayscale”. ‘-

5. Adjust the Bumpiness to a ——
smaller value. =

6. Click “Apply”. , ot —

/. Do the same thing for rock.jpg-. s e ‘




Rock
Shader | standard

Adding Normal Maps Ea—

o Albedo 2

(P - 8

1. Select level in the Hierarchy pane e
again. = =

2. In the Inspector pane, drag & drop O e T
rock 1.png into the Rock’s Normal B 7
Map. e

3. Do the same thing for grass 1.jpg —® i —1
with Grass’ Normal Map.




Quick lexicon review

e Normal Map
o Industry-wide term for images that represents the direction light is
supposed to reflect off of a model’s surface
o Model’s UV-coordinates indicate how a normal map is supposed to be
mapped on the model



Adjust lighting

1. Click on "Directional Light" game object
under the Hierarchy pane.
2. Adjust the rotation in the Scene pane.

“= Hierarchy |
Create ~ 7'-‘4’*'«“

level
Main Camera
Directional Light

a. Quick-tip: hover the mouse on the Scene pane,
then tap F to focus on the selected object

3. Change the color and intensity of the
light in the Inspector pane.

Note: if the lighting doesn't change in the

Scene pane, make sure the lighting button

M Ligh @ %
| Directional 4|
Baking | Realtime $J
lor | I
S —_ 1
Bounce Intensity — s=(m— 1~ |
hadow | Soft Shadows 2.
Strength —) (1|
Resoll | Use Quality Settings |
Bias (s | 0,05 |
Normal o — 0.4 |
Cookie None (Texture)
Cookie Size 10
raw Hal O
lare None (Flare)
ender Mode | Auto |
lling Mask | Even ything |

is pressed T

yl Shaded ~| | 2cH | &
H 2 -




About Lighting

e Create new lights with L——J ““"éf.
“GameObject -> Light” | %L |
Light > Directional Light
Audio > Point Light
. DireCtionaI Light gzmcleSystem } Z‘:::I:.gi:;t
o A sunlight emitted in one direction ez Reflection Probe
. Point Light Center On Children Light Probe Group

o A glow emitting from a single point

e Spotlight
o A cone-shaped light used to simulate
flashlights and spotlights



Building an Executable

1. Save the scene with Ctrl+S/Cmd+S.
2. In the file menu, select "File -> Build
Settings..."

New Scene Ctrl+N  §
Open Scene Ctrl+0
Save Scene Ctrl+S
Save Scene as... Ctrl+Shift+S

New Project...
Open Project...

Save Project

Build Settings... Ctrl+Shift+B
Build & Run Ctrl+B
Build in Cloud...

Exit




Building an Executable

1. Drag & drop your scene in the Project pane into
the Build dialog .

2. Highlight
“scenes/SampleScene”,

Add Open Scenes
[]
and hit the delete key SRR 0 v e
(] | {
E i0s Target Platform _Windoms 3]
‘ Archtecture o E—

u Ancroid Capy PDB files
Create Visual Studio Solution

== Universal Windows Platform

.
U WebGL
“ Facehoak

| @y VoS | compression Method ~ Default

@ Xbox Cne
|
Switch P

m || Player Settings... | [ Build || Build And Run




Building an Executable

3. Change the Target Platform to your computer's
OS

4. Click the "Build" button,
and select a folder that
Isn’t in your project

666666




Save project

Select “File -> Save Project”

e Saves project settings, such as Build Settings

e Saves anything import settings in the Project Pane

e Saves any Unity files that isn’t a scene, such as
materials, prefabs, physics materials, etc. [ et s cameo



Congratulations!

Any guestions?




Supplementary materials

e http://unity3d.com/learn/tutorials
a. Official site full of tutorials on individual
Unity feature
b. Includes in-depth C# programming
tutorials!



http://unity3d.com/learn/tutorials

