Unity VR Development
Using Unity




Goal

Get comfortable with Unity game editor

Create an interactive 3D environment

Learn lots of 3D development terms

A brief start in C# programming

Note #1: we will not cover how to setup Oculus
Rift, Samsung Gear, or Google Cardboard to work
on your computer

Note #2: we will not cover Android SDK Manager
either



Starting a new project

Step 1: Click “"New”




Starting a new project

Step 2: Type in a project name and the folder it'll be

created in.
Note: Unity will create a new folder with the project’s name

Crash Course Unitﬂ

CAUsers\taro_2\Fossil




Starting a new project

Step 4: Click “"Asset packages...”,
and check “Characters,”
“CrossPlatformInput,” and
“Prototyping.” Lastly, click
“Done.”

Note: the rest of the packages
can be imported at any time!

Asset packages




Starting a new project

Step 5: Finally, click “Create project”

Crash Course Unity

CAUsers\taro_2\Fossil

| Asset packages... ||T|
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For Android users, click “Edit -

> Preferences...”

Click “External Tools” on the
sidebar

Set the SDK and JDK to the
proper folder using “Browse,”
or download and install them if
not installed.

Close “Unity Preferences”

We only need to do this once.

General

Colors
Keys

GI Cache
20

Cache Server

Add unityproj references...
i ‘ Editor Attaching -

Edit  Assets GameObject Component Mob
Undo Selection Change Ctrl+Z

Redo Ctrl+Y
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Duplicate Ctrl+D
Delete Shift+Del -
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External
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External Script
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Revision Control Diff/Merge TortaiseMerge
Tizen SDK Location | Browse...
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VR Setup

1. In the file menu, select "File ->
Build Settings..."

2. A new dialog, "Build Settings”
should open

Edit Assets  GameObject  Compor

Mew Scene Ctrl+M |
Open Scene Ctrl+0
Save Scene Ctrl+5
Save Scene as.. Ctrl+Shift+5
Mew Project...

Open Project...

Save Project

Build Settings... Ctrl+Shift+B
Build & Fun Ctrl+B
Build in Cloud...

Exit




VR Setup

1. Click and highlight the
platform that you plan on
building for.

2. If the “Switch Platform”
button is enabled, click
on it (if disabled, your

build settings is set |

proper|Y) " | switch Platform |fPlayer Settings... Bui:”l

Texture Compression |
Google Android Project |

Development Build |
Autoconnect Profiler |
Script Debugaging




VR Setup

1. Click on the “Player
Settings...” dialog.

2. Close the "Build Settings” &..... 1 D o
dialog (we'll return to it | revecsumusnsaonsct [ resre comrssn |
again). Eios Beoveen sl |

Autoconnect Profiler |

Script Debugaging

..E)q Tizen

Windows Store
WebGL .
. b Learn al

[ Switch Platform [ Player Settings... Build




1.

2.

On the right-most pane,
click on “Other Settings”
to expand it.

For Oculus & Samsung
Gear, check the “Virtual
Reality Supported”
checkbox.
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1. For Android users, change the
“Minimum API Level” to the
SDK version you have installed
(ideally, v5.1 or your device's
API level if lower).
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VR Setup

1.

2.

Also for Android users, click
“"Resolution and Presentation”
Change the "Default
Orientation” to “Landscape
Left.” This is to prevent any
auto-rotation.
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Other Settings

Publishing Settings




VR Setup

eeeeee

1. For Google Cardboard, select
“Assets -> Import Package ->

..............

Custom Package...” — .
2. Open “CardboardSDKForUnity. e

unitypackage” =e. =
3. Click "Import” o

oardaudioRoom.prefab [ HEL i
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Importing stuff

1. Go towp.me/a5G4dR-pW, and click the VR-With-Unity-

5-Assets link to download a ZIP file.

2. Unzip the file.

3. Open your favorite file browser.

4. From the unzipped files, move the 3D model level.fbx,
textures (images) grass.png and rock.jpg, sound
effect hit.wav, and script DragRigidbody.cs into the
project’s Assets folder.

5. Switch to Unity.



http://wp.me/a5G4dR-pW
http://www.techvalleygamespace.com/wp-content/uploads/2016/04/VR-With-Unity-5-Assets.zip
http://www.techvalleygamespace.com/wp-content/uploads/2016/04/VR-With-Unity-5-Assets.zip
http://www.techvalleygamespace.com/wp-content/uploads/2016/04/VR-With-Unity-5-Assets.zip

Asset License

Original files obtained from:

http://opengameart.org/content/machu-picchu

e level.fbx is a modified version of MPFull.blend from
ctdabomb, released under CC-by-sa 3.0

e grass.png is from samuncle, released under CC-by-sa
3.0

e rock.jpg is from Marianne Gagnon , release under CC-
by-sa 3.0

Link to CC-by-sa 3.0 license:

https://creativecommons.org/licenses/by-sa/3.0/legalcode



http://opengameart.org/content/machu-picchu
http://opengameart.org/content/machu-picchu
https://creativecommons.org/licenses/by-sa/3.0/legalcode
https://creativecommons.org/licenses/by-sa/3.0/legalcode

About Unity
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What is Unity?

e A What-You-See-Is-What-You-Get (WYSIWYG) 3D & 2D
Game Engine

e Many built-in features
o Physics, Sound, Scripting, Gamepad support, Plugins, and
more!
e Builds to many platforms
o PC, Mac, Linux, HTML5 + WebGL, iOS (iPhone + iPad),
Android, Windows 10, Windows 8, Kindle Fire, PS4, PS3,

PS VITA, Xbox One, Xbox 360, Wii U, New 3DS, Ouya,
Samsung TV, Tizen



Licenses and Fees

e Free license (what we're using now!)
o Build to Windows, Mac, Linux, Webplayer, HTML5 + WebGL, iOS,

Android, and Windows 10

o C# and Javascript(-ish) scripting support
o Totally OK to sell your game! There’s no royalty fees.

m Exception: if your company’s gross revenue/budget exceeds
$100,000, you need to purchase...
e Pro license ($1,500 or $75/month)
o Required if company gross revenue/budget exceeds $100,000

o Supports up to 2 computers per license
o Access to more platforms (PS4, Xbox One, Wii U, etc.)
O

Allow customizing splash screen



Making a game
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Project Pane

e Displays the contents of the Assets folder.
o Automatically syncs with the folder if there’s any changes

e Has a search bar to make it easier to find assets

'.é_PI’O-j-Ect—'.I Console | @@v| « Fossil » SiggraphlntroToUnity » L4 | 4 | | Search SiggraphlntroToUnity
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Add a model to a nhew scene

eeeeeeeeee

1. Select level.fbx in the Project |== TR T —
pane. -

2. Drag-and-drop level.fbx into
the Scene pane.

3. Press Ctrl+S/Cmd+S to save
the scene (or “File->Save
Scene”)  (fE) wi ases ameobject Compo

Mew Scene Ctri+M
Open Scene Ctrl+0
Save Scene Ctrl+5

Save Scene as... Ctri+5hift+5



Quick lexicon review

e Assets
o Industry-wide term for any files used in the game
o For Unity, that’s anything inside the Assets folder

e Models
o Industry-wide term for 3D sculpture files.
o Can contain animations.
o Usually made in a specialized program, e.g. Maya, Blender, etc.



Scene Pane

e A 3D view of a scene where objects can be positioned,
rotated, and scaled.

eeeee
|| shaded IES I ESE =T | sizmos -| Al




Importing 3D models

Unity can natively import:

FBX (*.fbx)

COLLADA (*.dae)

3D Studio (*.3ds)

Wavefront (*.0bj)

Draw Interchange Files (*.dxf)



Importing 3D models

If you have the following software installed on the same
computer Unity is, Unity can also import:

Blender (*.blend)

Maya (*.mb, *.ma)

3D Studio Max (*.max)

Modo (*.Ix0)

Cinema4D

Cheetah 3D (*.jas)

Lightwave



Navigating the scene pane

e 2-button mouse:
o Left-click to select objects

o Hold alt and left mouse button to rotate camera around scene origin
o Hold ctrl, alt, and left mouse button to pan
o Hold ctrl, alt, and right mouse button to zoom

e 3-button mouse:

o Left-click to select objects

o Hold right mouse button to rotate camera around camera position
o Scroll wheel to zoom in and out

o Click and hold on the scroll wheel to pan
e Hold shift to pan/rotate/zoom faster



Manipulating game objects

e Object controls, from left to right: [OEXS[=Z]E]
Pan View (Q)
Translate (W)
Rotate (E)
Scale (R) ) B

2D Spr|te (T) Translate (W) Rotate (E) Scale (R)

e Controls to toggle object’s reference point: el St

e Play Game controls, from left to right:
o Play game (or if already playing, stop game)
o Pause game (or if already paused, resume game)
o Move forward one frame

0O O O O O




Hierarchy Pane

e Displays the content of a scene in a tree
hierarchy.

e Objects selected in the Hierarchy-pane
are also selected in the Scene-pane, and
vice versa.

e You can change the order of the objects
by dragging them up and down

e Dragging objects into another turns that
object into a child (I'll go over this later)




Quick lexicon review

e Game Objects
o Unity’s term for any individual object
o Can be active or inactive
o Every entry in the Hierarchy pane is a game object

e Scene
o Unity’s term for files storing a collection of game objects
o Store references to assets in the Assets folder
o Has a *.unity file extension



Adding Texture to Model ==

1.
2.

Select level in the Hierarchy pane
In the Inspector pane, drag-and-
drop texture rock.jpg into materic
HortonRockWall2’'s Albedo
field, and grass.png into material
grass_dark’s Albedo field.
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Inspector Pane

o Displays the properties and o =

details on a selected object/file, | o s tliorer oo
bOth in PrOjeCt pane and Scene .v;‘;siti-:;rrla"s':ur;"—EEB.ﬂ Y 370.51 £ SE?;

pa ne- Scale ¥ 40 Y40 Z 40
e One can edit the properties of an |7, <= (st filten) as
object here. e —

Receive Shadows [

b Materials
Use Light Probes [+
Reflection Probes | Blend Probes il

Anchor Override None (Transfarm) EO




Importing Images

Unity can natively import:

Photoshop (*.psd)

PNGs (*.png)

JPEGs (*.jpg, *.jpeg)
Un-animated GIFs (*.gif)
Paint (*.bmp)

TGAs (*.tga)

and more!



Quick lexicon review

e T[extures

o Industry-wide term for images that represents how a model is
supposed to be painted

o Models usually contains coordinates (called UV) that indicate how a
texture is supposed to be mapped on the model

e Components
o Unity’s term for containers with specialized information
o Game objects retain a list of components (such as Transform)
o Can be enabled or disabled
o Every entry in the Inspector pane is a Component



Adding Camera

Let’s add a prefab (short for prefabricated object) with first-person controls

1. In the Hierarchy pane, select "Main Camera", and remove it by pressing
Delete/Cmd+Backspace. l e

2. In the Projects pane, search for
"FPSController"

3. Drag-and-drop "FPSController"
into the Scene pane.

4. Position the FPSController
above the ground




Google Cardboard

Google Cardboard users needs one more extra * oncracer De_f_a__u_itmsmae'
Setup Step: o / 'FPSC -tl_q:f'eir__.. :: bTraniflo.::-n == ! Appl.?ﬂ%}
1. In the Hierarchy pane, expand . B —

"FPSController” by clicking the triangle
2. Highlight “FirstPersonCharacter”
3. In the Inspector pane, click “Add
Component”
4. Search for "StereoController,” and click
on the listed entry

.--SterenCan'tmlieir'
Clip @ StereoRenderEffect
New Script

@ %
Add Component ]




Playing the Game

1. Press the play button. 2Lt L]
2. Observe your camera...fall through the floor.
3. Press the play button to stop the game.

4. What are we missing?



Adding a Collider

The ground needs a collider =
1. In Scene pane, select level. ~e

~% Rigidbedy

2. In the Inspector pane, click "Add - Charcter Conrole

L Box Callider

Component” @iire callde

@ Capsule Collider
3. Select "Physics -> Mesh Collider” ———giei

Add Component

“®Hinge Joint
“#*Fixed Joint
IT [:zi M Mesh collider ﬁ #*,
Convex -
i Is Trigger ]
| Material None (Physic Material)| @

| Mesh il Level @



Playing the Game

1. Press the play button. 2Lt L]

2. Use the mouse to look around, arrow keys (or WASD)
to move, space to jump, and shift to run.

3. Oculus and Samsung Gear users: moving the VR will
rotate the camera, too.

4. Marvel at your own work.



Quick lexicon review

e Prefab

o Unity’s term for prefabricated objects
o Files with *.prefab file extension
o Allows copying a group of game objects from one scene to another

e C(olliders

o Industry-wide term for shapes representing the boundaries of an
object
o Used by the physics engine to determine where objects collide



Types of colliders

e Mesh Colliders

o Collider that is the shape of a model’s surface
o Expensive and inefficient
o Best for static, non-interactable levels and objects

e Box Colliders
o Rectangle-shaped colliders

e Sphere Colliders

o Sphere-shaped colliders (no oval support)

e Capsule Colliders
o Capsule-shaped colliders (supports height, no oval support)



Removing head-bob

= Hierarchy |

® Inspector |
SLEpP WilseL

— ]

S

Create 7| (arAll

By default, FPSController has head-bob b Skin width

turned on, which is bad for VR: / E;.’.E'm' i d o C—
1. In the Hierarchy pane, highlight Height

v Eﬂ [ First Person Controller (Script)

"FPSCOI"]trO”er" Seript |:lFil'stPersr_-nC-:-ntr-:-ll-el'

Is Walking

2. In the Inspector pane, uncheck “Use Walk Speed 3

Run Speed

Head BOb" Runstep Lenghten
Jump Speed 10

Stick To Ground Force |10

Gravity Multiplier Z
b Mouse Look

Use Fov Kick )
b Fov Kick

Use Head Bob O
# Head Bob



Adding interactive stuff

A\\ - I Component  Mob ileInput  Window Help
1. Select "3D Object -> Cube =
2. In the Scene pane, position the ' »>= s

new cube in front of the camera.
3. While leaving the "Cube" selected,
click "Add Component" under the
Inspector pane.
Select "Physics -> Rigidbody"
Play the game!

el 5=

14 Physics

T -

'!*Character Controller rl




Using a Script

1.

In the Project pane, select "DragRigidbody.cs"

2. Drag-and-Drop DragRigidbody.cs onto the
"FPSController" under the Hierarchy pane (NOT the
Scene pane!).

Play the game!

Face the camera to the Cube, and click & hold on it to
pick it up

W



Making weird shapes

1. Select “"3D Object -> Sphere”

2. In the Scene pane, position the new
sphere on an edge of a cube.

3. In the Hierarchy pane, drag & drop
the Sphere into the Cube.

4. The Sphere should now be a child of
Cube.

5. Play the game, and drag around the oo
cube+sphere!




Quick lexicon review

e Rigid Body

O
O

Industry-wide term for a moving and/or interactive physics objects
Contains information such as mass, drag, and center-of-gravity

o Turns a group of colliders (including those in the children) into a

single, interactable shape

e Child

©)

Industry-wide term for an object whose position, scale, and rotation
follows that of another object: the parent
In Unity, they appear as nested entries in the Hierarchy tree view

Trivia: this “following parent” calculation process is known as forward
kinematics, a term in 3D animations



Change some physics

W N

te

Right-click inside the Project pane,

and select “Create -> Physics
Material”

Name the file, “bouncy”

In the Inspector pane, change the
bounciness to 1 (as in, 100%)

Shader
Compute Shader

Prefab
Audio Mixer

Material

Lens Flare

Render Texture
Lightmap Parameters

-Elnspector | & =
& bouncy 2,
- | open |
Dynamic Friction 0.6
Static Friction 0.6
Bounciness [1 |
Friction Combin | Averag s
Bounce Combine | Averag ™
Friction Direction 2
®ao Y0 2.0

Dynamic Friction 2 0

Static Friction 2 ]




Change some physics

1. In the Hierarchy pane, select Cube

2. Drag & drop “bouncy” from the Project pane to Material
field under the Box Collider component in the Inspector
pane

3. Play the game, and throw the Cube end into the ground

¥ iy M Box Collider Qg %

o Edit Collider
LJ

: Is Trigger
£>Material Mone (Physic Material)

Center

=0 Y0 Z |0
Size
Al Yil 21




Quick lexicon review

e Physics Material

©)

Industry-wide term for how objects are supposed to interact to a

collider
m Adjusts how slippery and bouncy an object can be

In Unity, materials are files (*.physicMaterial) shared between game
objects

Changing a physics material’s properties will update all game objects
with the same physics material



Adding a Sound

Select the Cube in the Scene pane ‘

@Audin Listener

2. In the Inspector pane, click "Add
Component”

—

(v =] ¥ Audio Source G %
3. Select "Audio -> Audio Source” MM fow:  wemsmes
4. In the Project pane, drag-and- Al s e
drop hit.wav into the Audio e
Source component's "Audio Clip" e
property Pit ——o—1
5. Play the game! T




Adding a Script

R Wi

=

Select the Cube in the Scene pane

In the Inspector pane, click "Add Component”

Select "New Script”
Change the script type to CSharp, and the
script name to "PlaySoundOnCollision”
Click “Create and Add”

Double-click "PlaySoundOnCollision" in the
Inspector pane to open Editor

aaaaaaaa
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Copy the Following:

using UnityEngine;
public class PlaySoundOnCollision : MonoBehaviour
AudioSource audioCache;
vold Start () {
audioCache = GetComponent<AudioSource> () ;
}
vold OnCollisionEnter (Collision info) {
audioCache.Stop () ;
audioCache.Play () ;



Finishing the Sound Effect

1. Save the script (under “File” in the menu bar)

2. Switch to Unity

3. Select the cube in the Scene pane

4. Under the Inspector, uncheck Audio Source's "PIay -On
Awake" :

5. Change the "“Spatial Blend” to BD\

6. Play the game! \

(5] o
) o
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Script Summary

AudioSource audioCache;
void Start () {

| —

audioCache = GetComponent<AudioSource> () ;

The start () function runs when the game starts
GetComponent<AudioSource> () gets the Audio Source
component from the Game Object this script is attached to
audioCache = GetComponent<AudioSource> () stores
the Audio Source Component in a variable, audioCache



Script Summary

vold OnCollisionEnter (Collision info) {
audioCache.Stop () ;
audioCache.Play () ;

1. The OnCollisionEnter () function runs when the
Rigidbody collides with a collider

2. audioCache.Stop () makes the sound effect stop,
resetting it back from the beginning

3. audioCache.Play () makes the sound effect play
again



Importing Sound

Unity can natively import:
e WAV (*.wav)
o Best for short sound effects
e AIFF (*.aif, *.aiff)
o Best for short sound effects
e MP3 (*.mp3)
o Best for music, especially in mobile devices
o Remember, some mobile devices can only play one MP3 file at once

e OGG (*.0g9)

o Best for music, especially PC and consoles



Duplicating the Cube

1. Drag & Drop the object, "Cube" from the Hierarchy
pane to the Project pane. This creates a new
Prefab.

2. Drag & Drop the Cube prefab from the Project pane
to the Scene pane as many times as you I|ke This
will create many coples of Cube.




Importing Normal Maps

1. In the Project pane, select grass.png, . .
and press Ctrl+D/Cmd+D to duplicate it.

2. Click on grass 1.png. (St
3. In the Inspector, change the Texture |
Type to “Normal map”. | e
4. Check “Create from Grayscale”. .74 =
5. Adjust the Bumpiness to a — e =
smaller value. e o
6. Click "Apply”. S =
7. Do the same thing fmﬁ_ e
e | T




Select level in the Hierarchy pane
again.
In the Inspector pane, drag & drop
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@ Detail Albedo x:
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rock 1.png into the
HortonRockWall2's Normal Map.
Do the same thing for grass 1.jpg

with grass_dark’s Normal Map. -
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Adjust materials

e Adjust the Metallic
(reflectiveness) and Smoothness
(shininess) values under the
HortonRockWall2 and
grass_dark.

e Experiment with the color (next to
Albedo) by clicking on it, and
selecting a color in the color picker

I Elnspector | )
o HortonRockwall2 @ =

v Shader i_Stand:aﬁ:i v
Rendering Mode | Opague B

Main Maps

I:‘ @ MNormal Map

0.11
0.221
1
[ © Inspector | a-
. grass_darlk & #
ki Shader | Standard il
Rendering Mode | Dpagque
Main Maps
Worbeco [
@ Metallic Cr 0
Smoothness == 0.078



Quick lexicon review

e Normal Map

o Industry-wide term for images that represents the direction light is
supposed to reflect off of a model’s surface

o Model’s UV-coordinates indicate how a normal map is supposed to be
mapped on the model



Quick lexicon review

e Material

o Industry-wide term for what material the surface of a model is
supposed to look like (e.g. metal, plastic, non-shiny stuff)
o In Unity, materials are files (*.mat) shared between game objects

m Changing a material’s properties will update all game objects with

the same material

o Models retain information on how materials.are_ manned to its surface

o Normally, you have to create materials
by hand
m Unity conveniently made 2 for us!
o The Renderer component holds materials

3 project | Console

| Create ~

AN Models

4 Assets - Materials

o
T
| b i

(LAl Prefabs

0L Al Seripts

Vi3 Assets
k& Editor
== Materials
|  wEs standard Ass

grass_dark HortonRoc..



Adjust lighting

= Hierarchy |
Create = | (arall

1. Click on "Directional Light" game object
under the Hierarchy pane.
2. Adjust the rotation in the Scene pane.

level
Main Camera
Directional Light

a. Quick-tip: hover the mouse on the Scene pane, (" Em—
then tap F to focus on the selected object T e

3. Change the color and intensity of the e
light in the Inspector pane. T
Note: if the lighting doesn't change in the L T
Scene pane, make sure the lighting button s e

is pressed e




About Lighting

e Create new lights with S ol
“GameOb]eCt _> nght" | j[rje;t:j:::ptycmld AIt+Shn‘t+N' hf:::e I_‘TGI'E_;%E .
ii[;ribjm : ' Directional Light
Audio »|  Point Light
e Directional Light I et
o A sunlight emitted in one direction Comers Refiection Probe

" . Center On Children Light Probe Group
e Point Light

o A glow emitting from a single point
e Spotlight

o A cone-shaped light used to simulate
flashlights and spotlights



Building an Executable

1. Save the scene with Ctrl+S/Cmd+S.
2. In the file menu, select "File -> Build
Settings..."

Mew Scene Ctri+N |
Open Scene Ctrl+0
Save Scene Ctrl+5
Save Scene as... Ctrl+5Shift+5
Mew Project...

Open Project...

Save Project

Build Settings... Ctrl+ Shift+B
Build & Run Ctrl+B
Build in Cloud...

Exit




Building an Executable

1. Drag & drop your scene in the Project pane into
the Build dialog

2. Change the Target Platform
to your computer's OS

3. Click the "Build" button,
and select a folder that
Isn’t in your project




Save project

Select “File -> Save Project”

e Saves project settings, such as Build Settings

e Saves anything import settings in the Project Pane

e Saves any Unity files that isn’t a scene, such as
materials, prefabs, physics materials, etc.

Mew Scene

Open Scene

Save Scene

Save Scene as... C

Mew Project...
Open Project...

Save Project



Congratulations!

Any guestions?




Supplementary materials

e unity3d.com/learn/tutorials
a. Official site full of tutorials on individual
Unity feature
b. Includes in-depth C# programming
tutorials!



http://unity3d.com/learn/tutorials
http://unity3d.com/learn/tutorials

Supplementary materials

e docs.unity3d.com/Manual/index.html
a. Manual for Unity, including scripting
documentation
b. Alternatively, click the “help” icon in the
Inspector pane to bring up documentation

(G¥
Nt |



http://docs.unity3d.com/Manual/index.html
http://docs.unity3d.com/Manual/index.html

Supplementary materials

1. Open “"Window -> Asset Store” =
2. Search for “Unity VR Sample” -

Hierarchy Ctrl+4
Project Ctrl+5
: i Asset Store | nimation Ctrl+6

4 | & L ] Q Language:English Prifiler Ctrl+7
Aulfio Mixer Ctrl+8
¥ | Filters 4 Asset Store Ctrl+9
Version Control
VR Samples # Home
* 3D Models
ey *  Animation
Publisher:
Rating: Applications
Price: *  Audio

* Complete Projects

*  Editor Extensions
The Unity VR Samples pack is a great way to

get started in VR development. With this pack
of a menu-and 4 mini-games, you can build to

¥ Particle Systems

*  Scripting
Gculus DK2 and CearVR. See the ledrning . L3
material that accompanies this package to get F Serdoes
started here - *  Shaders
.. St

F  Textures & Materials

¥ Unity Essentials




Using Version Control?

e Select “Edit -> Project Settings ->
Editor”

e In the Inspector, change “Version
Control Mode” to “Visible Meta Files”

e Change "Asset Serialization Mode” to. =\
“Force Text” T\

e Select “File -> Save Project”

e \ersion the project’s “Assets” and
“ProjectSettings” folders (the rest can
be ignored)
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