Crash Course Unity 5

Introduction to how to use Unity 5




Starting a new project

Step 1: Click "New Project”




Starting a new project

Step 2: Type in a project name and the folder it'll be

created in.
Note: Unity will create a new folder with the project’s name

Crash Course Unity{
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Starting a new project

Step 4: Click "Asset packages...”,  asset packages

and check “Character” and
“Prototyping.” Lastly, click
“Done.”

Note: the rest of the packages
can be imported at any time!

[‘—/T' Characters ]

(] CrossPlatforminput

] Environment

[‘—/T "Prototyping }

| ParticleSystems




Starting a new project

Step 5: Finally, click “Create project”

Crash Course Unity

C:A\Users\taro_2\Fossil

/:) 0 -
3D 2L ‘ Create project
Asset es... 2




Importing stuff

1. Go to http://wp.me/a5G4dR-87, and download “Crash

Course Unity 5 Assets.zip”

2. Unzip the file.

3. Open your favorite file browser.

4. From the unzipped files, move the 3D model level.fbx,
textures (images) grass.png and rock.jpg, sound
effect hit.wav, and script DragRigidbody.js into the
project’s Assets folder.

5. Switch to Unity.


http://wp.me/a5G4dR-8Z

Asset License

Original files obtained from:

http://opengameart.org/content/machu-picchu

e level.fbx is a modified version of MPFull.blend from
ctdabomb, released under CC-by-sa 3.0

e grass.png is from samuncle, released under CC-by-sa
3.0

e rock.jpg is from Marianne Gagnon , release under CC-
by-sa 3.0

Link to CC-by-sa 3.0 license:

https://creativecommons.org/licenses/by-sa/3.0/legalcode



http://opengameart.org/content/machu-picchu
http://opengameart.org/content/machu-picchu
https://creativecommons.org/licenses/by-sa/3.0/legalcode
https://creativecommons.org/licenses/by-sa/3.0/legalcode

About Unity

€0 Unity Personal (64bit) - Untitled - Crash Course Unity - PC, Mac & Linux Standalone <DX11>
File Edit Assets GameObject Component Mobilelnput Window Help

m “’ | S | ool | IEI me [ Layers ~ | [ Layout 3|

HierarchT | # Scene | € Game i) Inspector | a
Create ~ Shaded ~||2D || % | <) | &ir Gizmos *| (O All
Main Camera "
Directional Light v

<Persp

B3 Project | B console &=
Create ~ o |4 S
¥ /Favorites 4 Assets

~Y

DL All Prefab)
(O All Seriptd

iii 49 ..

Editor Materials Standard A.. DragRigidb... grass hit level

» (& Editor
& Materials
v standard
v&& Charad
V& Firstl
& Al

> Rolle v

QFini:l;\ed updaﬂ;;g scripts / assemblies




What is Unity?

e A What-You-See-Is-What-You-Get (WYSIWYG) 3D & 2D
Game Engine

e Many built-in features
o Physics, Sound, Scripting, Gamepad support, Plugins, and
more!
e Builds to many platforms
o PC, Mac, Linux, Webplayer, HTMLS5, iPhone, iPod, iPad,
Android, Kindle Fire, Barnes & Noble Nook, Windows 8,

Blackberry, Wii U, New 3DS, PS4, PS3, PS VITA, Xbox
One, Xbox 360, Ouya, Samsung TV



Licenses and Fees

e Free license ($0) (what we're using now!)

o Build to Windows, Mac, Linux, Webplayer, HTMLS5, iOS, Android,
Blackberry, Windows App (Metro), and Windows 8 Phone

o C# and Javascript(-ish) scripting support
o Totally OK to sell your game! There’s no royalty fees.

m Unless your company’s gross revenue/budget exceeds $100,000,
in which you need to purchase...
e Pro license ($1,500 or $75/month)
o Required if company gross revenue/budget exceeds $100,000

o Supports up to 2 computers per license
o Access to more platforms (Wii U, PS4, Xbox One, etc.)
O

Allow customizing splash screen



Making a game

€0 Unity Personal (64bit) - Untitled - Crash Course Unity - PC, Mac & Linux Standalone <DX11>
File Edit Assets GameObject Component Mobilelnput Window Help

m “’ | S | ool | IEI me [ Layers ~ | [ Layout 3|

HierarchT | # Scene | € Game i) Inspector | a
Create ~ Shaded ~||2D || % | <) | &ir Gizmos *| (O All
Main Camera "
Directional Light v

<Persp

B3 Project | B console &=
Create ~ o |4 S
¥ /Favorites 4 Assets

~Y

DL All Prefab)
(O All Seriptd

iii 49

Editor Materials Standard A.. DragRigidb... grass hit level

» (& Editor
& Materials
v standard
v&& Charad
V& Firstl
& Al

> Rolle v

QFini:l;\ed updaﬂ;;g scripts / assemblies




Project Pane

e Displays the contents of the Assets folder.
o Automatically syncs with the folder if there’s any changes

e Has a search bar to make it easier to find assets
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Add a model to a nhew scene

1. Select level.fbx in the Project ==
pane. -

2. Drag-and-drop level.fbx into
the Scene pane.

3. Press Ctrl+S/Cmd+S to save
the scene (or “File->Save
Scene") Edit Assets GameObject Compol

New Scene Ctrl+N
Open Scene Ctrl+0
Save Scene Ctrl+S

Save Scene as... Ctrl+Shift+S



Quick lexicon review

e Assets
o Industry-wide term for any files used in the game
o For Unity, that’s anything inside the Assets folder

e Models
o Industry-wide term for 3D sculpture files.
o Can contain animations.
o Usually made in a specialized program, e.g. Maya, Blender, etc.



Scene Pane

e A 3D view of a scene where objects can be positioned,
rotated, and scaled.




Importing 3D models

Unity can natively import:

FBX (*.fbx)

COLLADA (*.dae)

3D Studio (*.3ds)

Wavefront (*.0bj)

Draw Interchange Files (*.dxf)



Importing 3D models

If you have the following software installed on the same
computer Unity is, Unity can also import:

Maya (*.mb, *.ma)

3D Studio Max (*.max)

Blender (*.blend)

Modo (*.Ix0)

Cinema4D

Cheetah 3D (*.jas)

Lightwave



Navigating the scene pane

e 3-button mouse:
o Left-click to select objects

Hold right mouse button to rotate camera around camera position
Scroll wheel to zoom in and out

Click and hold on the scroll wheel to pan

O

O

O
e 2-button mouse:

o Left-click to select objects
O
O
O

Hold alt and left mouse button to rotate camera around scene origin
Hold ctrl, alt, and left mouse button to pan
Hold ctrl, alt, and right mouse button to zoom

e Hold shift to pan/rotate/zoom faster



Manipulating game objects

e Object controls, from left to right: [CEIS[=[E]
Pan View (Q)
Translate (W)
Rotate (E)
Scale (R) ) B

2D Spr|te (T) Translate (W) Rotate (E) Scale (R)

e Controls to toggle object’s reference point: [Eeesl Sl

e Play Game controls, from left to right: DIl
o Play game (or if already playing, stop game)
o Pause game (or if already paused, resume game)
o Move forward one frame

0O O O O O




Hierarchy Pane

e Displays the content of a scene in a tree
hierarchy.

e Objects selected in the Hierarchy-pane
are also selected in the Scene-pane, and
vice versa.

e You can change the order of the objects
by dragging them up and down

e Dragging objects into another turns that
object into a child (I'll go over this later)




Quick lexicon review

e Game Objects
o Unity’s term for any individual object
o Can be active or inactive
o Every entry in the Hierarchy pane is a game object

e Scene
o Unity’s term for files storing a collection of game objects
o Store references to assets in the Assets folder
o Has a *.unity file extension



Adding Texture to Model

ooooooooooo

1. Select level in the Hierarchy pane

© Occlusion
© Emission

2. In the Inspector pane, drag-and- et
drop texture rock.jpg into materie
HortonRockWall2's Albedo
field, and grass.png into material Ao -

Main Maps

grass_dark’s Albedo field. e =

oooooooooo
oooooooooo

© Occlusion
© Emission
© Detail Mask

Tiling

aaaaaaaaaaaa
© Detail Albedo x2
oooooooooo

Tiling

UUUUU




Inspector Pane

e Displays the properties and . T

details on a selected object/file, || o el xliover ot 2

Select | Revert |

|

|

both in Project pane and Scene A meferm @

Position
Rotation X -90 YO 20

pa nel Scale X 40 Y 40 Z 40
e One can edit the properties of an 7., e (esh Filten). a®
object here. T e

Receive Shadows [V

G » i %

b Materials
Use Light Probes (M
Reflection Probes | Blend Probes s |

Anchor Override None (Transform) o |




Importing Images

Unity can natively import:

Photoshop (*.psd)

PNGs (*.png)

JPEGs (*.jpg, *.jpeg)
Un-animated GIFs (*.gif)
Paint (*.bmp)

TGAs (*.tga)

and more!



Quick lexicon review

e T[extures

o Industry-wide term for images that represents how a model is
supposed to be painted

o Models usually contains coordinates (called UV) that indicate how a
texture is supposed to be mapped on the model

e Components
o Unity’s term for containers with specialized information
o Game objects retain a list of components (such as Transform)
o Can be enabled or disabled
o Every entry in the Inspector pane is a Component



Adding Camera

Let’s add a prefab (short for prefabricated object) with first-person controls

1. In the Hierarchy pane, select "Main Camera", and remove it by pressing
Delete/Cmd+Backspace.

2. In the Projects pane, search for
"FPSController"

3. Drag-and-drop "FPSController"
into the Scene pane.

4. Position the FPSController
above the ground

< FPSController




Playing the Game

1. Press the play button.
2. Observe your camera...fall through the floor.
3. Press the play button to stop the game.

4. What are we missing?



Adding a Collider

The ground needs a collider = |

Add Component ‘

1. In Scene pane, select level. :

~ Rigidbody

2. In the Inspector pane, click "Add & Character Controller

W Box Collider

Component” @5shers Colder

@ Capsule Collider

3. Select "Physics -> Mesh Collider" ———LIEETTS_——
# Terrain Collider

:;;il:tt;: Jo.int

v ;2 M Mesh collider @ =
Convex ]

Is Trigger
il Material None (Physic Material) ©
I

1 Mesh U Level [0}




Playing the Game

1. Press the play button.

2. Use the mouse to look around, arrow keys (or WASD)
to move, space to jump, and shift to run.

3. Marvel at your own work.



Quick lexicon review

e Prefab

o Unity’s term for prefabricated objects
o Files with *.prefab file extension
o Allows copying a group of game objects from one scene to another

e C(olliders

o Industry-wide term for shapes representing the boundaries of an
object
o Used by the physics engine to determine where objects collide



Types of colliders

e Mesh Colliders

o Collider that is the shape of a model’s surface
o Expensive and inefficient
o Best for static, non-interactable levels and objects

e Box Colliders
o Rectangle-shaped colliders

e Sphere Colliders

o Sphere-shaped colliders (no oval support)

e Capsule Colliders
o Capsule-shaped colliders (supports height, no oval suppport)



Adding interactive stuff

GameObject | Component MobileInput Window Help

1. Select “"3D Object -> Cube” oy ey [
2. In the Scene pane, position the ' »*= 0 T

new cube in front of the camera.
3. While leaving the "Cube" selected,
click "Add Component" under the
Inspector pane.
Select "Physics -> Rigidbody"
Play the game!

el 5=

Q|

Physics

4. Rigidbody
& Character Controller rl




Using a Script

1.

In the Project pane, select "DragRigidbody.js"

2. Drag-and-Drop DragRigidbody.js onto the
"FPSController" under the Hierarchy pane (NOT the
Scene pane!).

Play the game!

Move the cursor to the Cube, and click+hold on it to
pick it up

W



Making weird shapes

1. Select “"3D Object -> Sphere”

2. In the Scene pane, position the new
sphere on an edge of a cube.

3. In the Hierarchy pane, drag & drop
the Sphere into the Cube.

4. The Sphere should now be a child of Oiectonal it '.
Cube. S

5. Play the game, and drag around the M —
cube+sphere!




Quick lexicon review

e Rigid Body
o Industry-wide term for an interactive physics objects
o Contains information such as mass, drag, and center-of-gravity

o Turns a group of colliders (including those in the children) into a
single, interactable shape

e Child

o Industry-wide term for an object whose position, scale, and rotation
follows that of another object: the parent
o In Unity, they appear as nested entries in the Hierarchy’s tree view



Change some physics

1. Right-click the Project pane, and

Delete

select “Create -> Physics Material” i | =
Name the file, “bouncy” g
In the Inspector pane, change the -

bounciness to 1 (as in, 100%)

Render Texture

I

Lightmap Parameters

Animator Controller
Animation

Ctrl+R

S

Animator Override Controller
Avatar Mask

Physic Material

© Inspector | @
© bouncy %,
A (Open]
Dynamic Friction 0.6
Static Friction 0.6
Bounciness |1 |
Friction Combine | Average ™
Bounce Combine | Average s]
Friction Direction 2
X0 Y 0 Z|0
Dynamic Friction 2 0
Static Friction 2 0




Change some physics

1. In the Hierarchy pane, select Cube

2. Drag & drop “bouncy” from the Project pane to Material
field under the Box Collider component in the Inspector
pane

3. Play the game, and throw the Cube end into the ground

v iy M Box Collider ¥,

o | 4 | Edit Collider

=7/ Is Trigger (]
._‘\L:>Material None (Physic Material) [o]
nter

hgdnky %0 Van) z'o

X1 yl1 z1




Quick lexicon review

e Physics Material

©)

Industry-wide term for how objects are supposed to interact to a

collider
m Adjusts how slippery and bouncy an object can be

In Unity, materials are files (*.physicMaterial) shared between game
objects

Changing a physics material’s properties will update all game objects
with the same physics material



Adding a Sound

Select the Cube in the Scene pane : Audio

@Audio Listener

2. In the Inspector pane, click "Add

—

Component” . S —
3. Select "Audio -> Audio Source" o o s o
4. In the Project pane, drag-and- e

drop hit.wav into the Audio s 4

Source component's "Audio Clip" o

property —— =
5. Play the game! i T




Adding a Script

R Wi

=

Select the Cube in the Scene pane

In the Inspector pane, click "Add Component”

Select "New Script”
Change the script type to CSharp, and the
script name to "PlaySoundOnCollision”
Click “Create and Add”

Double-click "PlaySoundOnCollision" in the
Inspector pane to open Editor

New Script

s Play Sound On Collision (Script)@ ¥,

| © PlaySoundOnCollisior] @




Copy the Following:

using UnityEngine;
public class PlaySoundOnCollision : MonoBehaviour
AudioSource audio;
vold Start () {
audio = GetComponent<AudioSource> () ;
}
vold OnCollisionEnter (Collision info) {
audio.Stop () ;
audio.Play () ;



Finishing the Sound Effect

R Wi

Save the script (Ctrl + S)

Switch to Unity

Select the cube in the Scene pane

Under the Inspector, uncheck Audio Source's "Play-On

Awake"

Gl %

P|ay the game! v & @ Audio Source _

AudioClip

Output

Mute

Bypass Effects
Bypass Listener Effe
Bypass Rever b Zone
Play On Awake

Loop

DRCO00=

ne (Audio Mixer GroL ©



Script Summary

AudioSource audio;
void Start () {

=

audio = GetComponent<AudioSource> () ;

The start () function runs when the game starts
GetComponent<AudioSource> () gets the Audio
Source component from the Game Object this script is
attached to

audio = GetComponent<AudioSource> () stores
the Audio Source Component in a variable, audio



Script Summary

volid OnCollisionEnter (Collision info) {
audio.Stop () ;
audio.Play () ;

1. TheonCollisionEnter () function runs when the
Rigidbody collides with a collider

2. audio.Stop () makes the sound effect stop, resetting
it back from the beginning

3. audio.Play () makes the sound effect play again



Importing Sound

Unity can natively import:
e WAV (*.wav)
o Best for short sound effects
e AIFF (*.aif, *.aiff)
o Best for short sound effects
e MP3 (*.mp3)
o Best for music, especially in mobile devices
o Remember, some mobile devices can only play one MP3 file at once

e OGG (*.0g9)

o Best for music, especially PC and consoles



Duplicating the Cube

1. Drag & Drop the object, "Cube" from the Hierarchy
pane to the Project pane. This creates a new
Prefab.

2. Drag & Drop the Cube prefab from the Project pane
to the Scene pane as many times as you like. This
will create many copies of Cube. e

. Favo Ass
Ol all Materials
OL All Models
f

' — v
OLAll Prefabs -
Ol all Seripts o VA
R ———
™ Assets ‘ MR it
P




Importing Normal Maps

Lo e

ol =

N o

In the Project pane, select grass.png,

and press Ctrl+D/Cmd+D to duplicate it.

Click on grass 1.png.
In the Inspector, change the Texture

Type to "Normal map”. —

Check “Create from Grayscale”.

Adjust the Bumpiness to a
smaller value. T

Click “Apply”. ot
Do the same thing for rock.jpg.

CICECN  grass 1
| © Inspector |
[ . grass 1 Import Settings
Texture Type | Texture
‘ Alpha from Grayscale | o/  Tedure
1 Yrep=ilods > Normal map
® Inspector | a8 .=
. grass 1 Import Settings &
| J
Texture Ty | +)
Create from Grayscaldy
Bumpiness 0.092
Filtering | &)
Wrap Mod, | Repeat ¢
:




Adding Normal Maps

1. Select level in the Hierarchy pane
again.

2. In the Inspector pane, drag & drop
rock 1.png into the
HortonRockWall2's Normal Map.

3. Do the same thing for grass 1.jpg

Wil
with grass_dark’s Normal Map. |

sssssss

o Detail Mask
Tiling
ooooo
aaaaaaaaaaaa

© Detail Albedo xi

Tiling
OOOOO

0
|||||
set
aaaaaaaaaaaa
© Detail Albedo xi
al M
Tiling X ]
OOOOO X
uv set Y] + |
. grass_dark @ %
v W Sshader | Stand ard >
Rendering Mode | Opaque
Main Maps
. o Albedo . 2
o Metallic e 0
Othness s | 0,5
| Map




Adjust materials

e Adjust the Metallic
(reflectiveness) and Smoothness
(shininess) values under the
HortonRockWall2 and
grass_dark.

e Experiment with the color (next to
Albedo) by clicking on it, and
selecting a color in the color picker

70 Inspector | )
' ' HortonRockwall2 G =
| v Shader ’ﬁtanda?d 3
Rendering Mode | Opaque s
Main Maps
o Albedo :] v
@ Metallic — 0.11
Smoothness 0.221
DONormal Map 1
:_“6—1 spect- { o -
. grass_dark [ 2,
| v Shader | Standard .
Rendering Mode | Opaque &
Main Maps
B o Albedo s
© Metallic 0
Smoothness =) 0.078
I:IoNormal Map 1




Quick lexicon review

e Normal Map

o Industry-wide term for images that represents the direction light is
supposed to reflect off of a model’s surface

o Model’s UV-coordinates indicate how a normal map is supposed to be
mapped on the model



Quick lexicon review

e Material

o Industry-wide term for what material the surface of a model is
supposed to look like (e.g. metal, plastic, non-shiny stuff)
o In Unity, materials are files (*.mat) shared between game objects

m Changing a material’s properties will update all game objects with

the same material

o Models retain information on how materials_.are manned to its surface

o Normally, you have to create materials
by hand
m Unity conveniently made 2 for us!
o The Renderer component holds materials

@ Project | [ console

SIEALE.S s
“LAll Models 4 pssets » Materials
‘LAl prefabs S

{00 All Scripts ST

A

v Assets S5y
» & Editor

grass_dark  HortonRoc..

| vk standard Ass



Adjust lighting

1. Click on "Directional Light" game object |t

under the Hierarchy pane.
2. Adjust the rotation in the Scene pane.

Main Camera
Directional Light

a. Quick-tip: hover the mouse on the Scene pane, w E—
then tap F to focus on the selected object %:’

3. Change the color and intensity of the T e
light in the Inspector pane. e
Note: if the lighting doesn't change in the T R—
Scene pane, make sure the Ilghtmg button | s S

is pressed e




About Lighting

e Create new lights with ™| et

GameObject | Component MobileInput Window Help

“GameObject -> Light” | R —
i:;:tbjm : Directional Light
Audio » Point Light
o Directional Light (s
o A sunlight emitted in one direction ez Reflection Probe

= = Center On Children Light Probe Group
e Point Light

o A glow emitting from a single point
e Spotlight

o A cone-shaped light used to simulate
flashlights and spotlights




Building an Executable

1. Save the scene with Ctrl+S/Cmd+S.
2. In the file menu, select "File -> Build
Settings..."

New Scene Ctrl+N
Open Scene Ctrl+0
Save Scene Ctrl+S
Save Scene as... Ctrl+Shift+S

New Project...
Open Project...

Save Project

Build Settings... Ctrl+Shift+B
Build & Run Ctrl+B
Build in Cloud...

Exit




Building an Executable

1. Drag & drop your scene in the Project pane into
the Build dialog

2. Change the Target Platform
to your computer's OS

3. Click the "Build" button,
and select a folder that
Isn’t in your project




Save project

Select “File -> Save Project”

e Saves project settings, such as Build Settings

e Saves anything import settings in the Project Pane

e Saves any Unity files that isn’t a scene, such as
materials, prefabs, physics materials, etc. Edit_Assets_GameO



Congratulations!

Any guestions?




